?
快捷搜索:  as  test  1111  test aNd 8=8  test++aNd+8=8  as++aNd+8=8  as aNd 8=8

长沙闲来麻将:龙都国际唯一网站:实战OSPF的路由再分配

?

长沙转转麻将必胜口诀 www.fv7j.com.cn 路由再分配涉及到将路由信息从某个源(平日是某种路由协议)发送到另一个源(平日是另一种路由协议)。

现在,我们来具体看看到底什么是路由再分配,让我们来做一个实际的路由再分配的实验。一种环境便是必要应用一些收集设备,而这些设备并不支持收集中的路由协议。

假如要用这些设备,必要把路由信息从设备中引入到你所在收集应用的路由协议中去。现在让我们来对于这样的环境,并反省每一种设备是否获得了精确的设置设置设备摆设摆设。

假设,你所在的企业收集有一个防火墙,它仅仅支持路由信息协议,即Routing Information Protocol(RIP)。你盼望把这个防火墙作为收集的默认网关,然而,收集却又运行着开放最短路径优先协议,即Open Shortest Path First (OSPF)。

你若何才能把默认的RIP路由信息放到OSPF收集中去呢?谜底便是路由重分配。首先,现在先看看图A所示的收集。

图A

防火墙在图的顶部,连接着路由器1.路由器1连着路由器2(在实际收集里面,还可能继承连下去)。

路由器1便是我们的重分配点。在这里我们将对来自防火墙的RIP路由信息重分配,然后放入到OSPF收集中。是以,路由器1必要运行RIP和OSP龙都国际唯一网站F协议。即在连接防火墙的接口上运行RIP,在连接路由器2的接口上运行OSPF.

这一步停止后,我们必要不雅察路由器2的默认路由,最初这由防火墙设置完成。只有路由器1具备默认路由的时刻,路由器2才会有默认路由。这里异常紧张:只管你可以持续从路由器1发送默认路由到路由器2而无需应用重分配,你照样必要使得路由器2具备默认路由。

下面便是路由器1的IP地址设置设置设备摆设摆设

interface Ethernet0

ip address 1.1.1.125 255.255.255.0

!

interface Serial0

ip address 2.2.2.1 255.255.255.0

路由器1的路由设置设置设备摆设摆设

router ospf 1

redistribute rip subnets

network 2.2.2.0 0.0.0.255 area 0

default-information originate

!

router rip

network 1.0.0.0

我们可以看到,路由器在串口上启用了OSPF ,在以太口上启用了RIP.此外,你必要留意下面这些敕令:

redistribute rip subnets:

在OSPF路由历程中,该敕令将把任何应用RIP协议收集收到的路由信息发给OSPF.subnet关键字高速路由器对所有收集(包括子网)进行重分配。按照默认设置,该敕令将会仅仅对标准收集重分配。

default-information originate:

在OSPF路由历程中,该敕令将容许OSPF广播默认路由。按照默认设置,该敕令将仅仅对切实着实存在的独一默认路由进行广播。然而,你也可以在敕令末端应用always关键字提示路由器经由过程OSPF广播默认路由,而不管路由到底是不是独一存在的。

现在,来看看路由器2的IP地址设置设置设备摆设摆设:

interface Ethernet0

ip address 10.1.1.1 255.255.255.0

!

interface S龙都国际唯一网站erial0

ip address 2.2.2.2 255.255.255.0

clockrate 250000

这是路由器2的路由设置设置设备摆设摆设:

router ospf 1

network 10.1.1.0 0.0.0.255 area 0

network 2.2.2.0 0.0.0.255 area 0

留意路由器2仅仅运行OSPF.

接下来,让我们在路由器1上运行show ip route敕令。下面便是输出结果:

R1# show ip route

Codes:

C - connected, S - static, R - RIP, M - mobile, B?BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA e龙都国际唯一网站xternal type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is 1.1.1.126 to network 0.0.0.0

1.0.0.0/24 is subnetted, 1 subnets

C 1.1.1.0 is directly connected, Ethernet0

2.0.0.0/24 is subnetted, 1 subnets

C 2.2.2.0 is directly connected, Serial0

10.0.0.0/24 is subnetted, 1 subnets

O 10.1.1.0 [110/74] via 2.2.2.2, 00:13:19, Serial0

R* 0.0.0.0/0 [120/1] via 1.1.1.126, 00:00:03, Ethernet0

留意,路由器1经由过程RIP接管到了默认路由,正如输出信息着末面仅靠0.0.0.0/0默认路由的R标志所表示的那样。你还必要留意,路由器1和路由器2经由过程OSPF通信。由于路由器1对路由器2上的以太网有10.1.1.0/24这条路由。

现在在路由器2上运行show ip route,结果如下:

R2# show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B?BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

E1 - OSPF exter龙都国际唯一网站nal type 1, E2 - OSPF external type 2, E?EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

U - per-user static route

Gateway of last resort is 2.2.2.1 to network 0.0.0.0

1.0.0.0/8 is subnetted, 1 subnets

O E2 1.1.1.0 [110/20] via 2.2.2.1, 00:12:39, Serial0

2.0.0.0/8 is subnetted, 1 subnets

C 2.2.2.0 is directly connected, Serial0

10.0.0.0/8 is subnetted, 1 subnets

C 10.1.1.0 is directly connected, Ethernet0

O*E2 0.0.0.0/0 [110/1] via 2.2.2.1, 00:12:31, Serial0

R2#

留意,路由器2有指向路由器1的0.0.0.0/0默认路由(本例中即2.2.2.1),并且路由信息带有O标志,即表示这是OSPF路由。

这是一条外部OSPF路由,正如E2标志所示。这注解路由的原并不是OSPF路由,而是另一种路由协议重分龙都国际唯一网站配而来。

路由器2并没有RIP路由,由于它并没有运行RIP.然则,经由过程重分配,路由器2能够接管防火墙所广播的RIP路由。

免责声明:以上内容源自网络,版权归原作者所有,如有侵犯您的原创版权请告知,我们将尽快删除相关内容。

您可能还会对下面的文章感兴趣: